All Posts

1F
莊浩志
: 更新後~~網站進不去
2020-01-01 19:59

就再也進不去網站了

2F
tad
:
2020-01-02 14:26

請參考: https://campus-xoops.tn.edu.tw/modules/tad_book3/page.php?tbdsn=1500

 

1F
hirokofan
: 即時空氣品質及天氣(air_weather) 區塊造成網頁無法開啟
2019-10-07 08:50

最近有學校發現網站無法開啟,需要將「即時空氣品質及天氣」區塊關閉才會正常,請問有學校遇到類似的情形嗎?

我測試的狀況是,如果使用「主要AQI資料來源」就會造成網頁無法開啟,將主要AQI來源註解後使用「次要AQI資料來源」則是正常的

(直接連https://opendata.epa.gov.tw/ 看不出有什麼問題)

2F
tad
:
2019-10-07 08:52

有發現,7:30~8:30這段時間會出問題

1F
黃子欣
: 這是給「tad」的悄悄話喔!
2019-08-20 20:08
這是給「tad」的悄悄話喔!
2F
tad
:
2019-08-21 12:55

檢查是否有刪除 modules/system/themes/legacy

3F
黃子欣
:
2019-08-21 13:31
這是給「黃子欣」的悄悄話喔!
4F
tad
:
2019-08-21 23:26
這是給「黃子欣」的悄悄話喔!
5F
黃子欣
:
2019-08-22 00:00
這是給「黃子欣」的悄悄話喔!
6F
tad
:
2019-08-22 00:07

display_errors 沒開

這樣為什麼錯誤也都看不出來阿~

7F
黃子欣
:
2019-08-22 20:24
這是給「黃子欣」的悄悄話喔!
8F
黃子欣
:
2019-08-27 20:29
這是給「黃子欣」的悄悄話喔!
9F
tad
:
2019-08-27 22:22

明天是台中最後一場的升級研習

其實有問題的學校都可以來聽聽

10F
tad
:
2019-08-27 22:24

手動把 tad_admin (站長工具箱急救版) 裝上去

然後用他把所有模組更新完即可

1F
茶米吉米
: 已經手動下載模組,並更新,但是後台還是一直出現,需要更新訊息
2019-05-14 13:29

老師好

 

已經手動下載模組(tadtools 與 tad_adm),並更新,但是後台還是一直出現,需要更新訊息

 

請問應該要如何解決?

 

2F
茶米吉米
:
2019-05-14 13:30
這是給「茶米吉米」的悄悄話喔!
3F
tad
:
2019-05-14 13:52

那個無關緊要吧~

1F
茶米吉米
: 更新完TAD_ADM後,進入線上更新,一片空白
2019-05-10 17:41

 

老師好

更新完TAD_ADM後,進入線上更新,一片空白

2F
茶米吉米
:
2019-05-10 17:42
這是給「茶米吉米」的悄悄話喔!
3F
tad
:
2019-05-10 18:09
https://www.tad0616.net/modules/tadnews/index.php?nsn=282
4F
茶米吉米
:
2019-05-12 14:21

請問,發生什麼事情?

http://campus-xoops.tn.edu.tw/uploads/tad_discuss/image/.thumbs/DiscussID_6298_1.jpg
5F
tad
:
2019-05-12 14:40

https://www.tad0616.net/modules/tadnews/index.php?nsn=282

這個網址上寫的內容還不夠清楚?

手動下載tadtools、tad_adm,解壓上傳覆蓋...

6F
茶米吉米
:
2019-05-12 18:50
這是給「茶米吉米」的悄悄話喔!
7F
tad
:
2019-05-12 19:07

遠端桌面連不上

不過從訊息研判,看起來就是tadtools不是最新版

確定有放對目錄?或有有無全部覆蓋?

8F
tad
:
2019-05-12 19:09

直接給我ssh帳密試試好了

9F
茶米吉米
:
2019-05-12 19:42
這是給「茶米吉米」的悄悄話喔!
10F
tad
:
2019-05-12 20:37

您把tadtools工具包反安裝了,導致天下大亂...

已幫您修復。

11F
茶米吉米
:
2019-05-12 20:42

感謝老師

您辛苦了~

12F
茶米吉米
:
2019-05-12 20:46

老師好

 

我像要讓xoops升級成為XOOPS 2.5.10 正體中文版

但是一樣會出現錯誤訊息?!

http://campus-xoops.tn.edu.tw/uploads/tad_discuss/image/.thumbs/DiscussID_6306_1.png
1F
Charlie
: 透過模組隨選改佈景主題發生的問題
2019-03-16 15:30

請問tad老師,目前使用最新的xoops 2.5.9的安裝檔以及最新的tadtools&tad_adm模組,

當我透過模組隨選修改佈景時都無法成功,以下圖片是這些錯誤訊息

不管是windows系統或Linux都是這樣的情況,

麻煩老師了

 

2F
tad
:
2019-03-16 19:45

不清楚,憑這樣的線索看不出所以然

3F
Charlie
:
2019-03-16 20:21

目前架設的是全新的網站

 

是使用CentOS-7-x86_64-Minimal-1810

xampp for linux(7.3.2)架設

檔案為:

XoopsCore25-2.5.9_tw_20170803

tadtools_3.23_20190124.zip

 tad_adm_2.8_20190101.zip

直接正常安裝,其他功能都算正常,但如果要更換佈景

就會跳出此錯誤,無法正常回到首頁,

發現主要的錯誤訊息都是這個:

錯誤: Error: Call to undefined function web_error() 在檔案中的第 /modules/tadtools/TadDataCenter.php 332

這樣的資訊是否夠老師了解狀況

麻煩了

4F
Charlie
:
2019-03-16 22:58

自己排除了,老師謝謝您

1F
王仲仁
: 無法安裝或更新模組
2019-02-25 11:11

如附件,應該是 Linux主機問題。 不知道要如何解決

2F
tad
:
2019-02-25 11:12

只有這樣的資訊,

我也不清楚...

3F
王仲仁
:
2019-02-25 11:40

apache:apache 0755 

應該是說 Linux  apache  這個帳號權限問題 ... 不知道 我有沒有解讀錯 

還是 只是顯示 apache:apache  0755   目錄的擁有者是誰  還有目錄的權限狀況 ?

4F
tad
:
2019-02-25 11:47

先確認目前apache的使用帳號為何(以debian為例是 www-data)

如果apache的使用帳號就是apache

那表示該目錄可以直接用瀏覽器更新,無須ssh

我最多只能從圖片解讀這些,其餘不清楚

1F
沈偵鳳
: 有關利用站長工具箱內XOOPS升級至2.5.9後遇到問題
2019-02-12 13:32

不好意思 當我利用站長工具箱升級至2.5.9後 系統設定管理區首頁  區塊 群組等每個功能進入後皆一片空白,需請求協助已嘗試利用補釘修補

2F
tad
:
2019-02-12 13:47

那就是沒完成升級步驟

請瀏覽器執行以下語法即可

http://網址/upgrade

 

3F
沈偵鳳
:
2019-02-13 18:02
這是給「沈偵鳳」的悄悄話喔!
4F
tad
:
2019-02-14 10:56

給我網址帳密吧。

5F
沈偵鳳
:
2019-02-14 17:39
這是給「沈偵鳳」的悄悄話喔!
6F
tad
:
2019-02-15 12:12

http://網址/modules/system/admin.php?fct=modulesadmin&op=update&module=system

至少完成系統更新

另外刪除 C:\my_xoops\www\modules\system\themes\legacy\ 資料夾

1F
Benjamin Franklin
: 這是給「tad」的悄悄話喔!
2019-01-04 23:43
這是給「tad」的悄悄話喔!
2F
tad
:
2019-01-06 17:55

沒有跑出ssh表示您的modules目錄是可以寫入的

您可以把modules改成755或644試試(含底下所有檔案目錄)

3F
Benjamin Franklin
:
2019-01-08 00:48
這是給「Benjamin Franklin」的悄悄話喔!
1F
hsun
: 模組隨選無法取清單
2019-01-03 09:53

tad 您好

今天發現 2.74 無法進入模組隨選的功能,以為是檔案沒更新的關係

後來更新成 2.8 後,模組隨選的功能還是進不去,會出現無法取得清單

 

2F
tad
:
2019-01-03 09:54

請到站長工具箱的偏好設定修改設定

3F
hsun
:
2019-01-03 12:36

更新成 ip 後,正常顯示了。感謝