All Posts

1F
吳文宏
: 這是給「tad」的悄悄話喔!
2019-12-11 15:43
這是給「tad」的悄悄話喔!
1F
小梁
: 校園食材登錄平台修改資安設定重新開站後,午餐資訊便抓不到每天的午餐內容
2019-09-24 13:15

如標題,我確定過學校代號是正確的,有勞Tad老師協助處理,謝謝Tad老師。

2F
tad
:
2019-09-24 14:17

啥資訊都沒留,無法處理

3F
小梁
:
2019-09-24 23:24

今晚再試一次擷取午餐資訊,突然又可以用了~其實我也什麼事都沒做,謝謝您!

1F
茶米吉米
: 出現錯誤訊息
2019-04-13 08:44

老師好

我在mytabs模組中,要執行加入區塊到頁籤中(加入今日午餐資訊區塊到標籤中)出現錯誤訊息

如圖片

2F
茶米吉米
:
2019-04-13 08:45
這是給「茶米吉米」的悄悄話喔!
1F
Benjamin Franklin
: mytabs (我的標籤)模組,放入午餐資訊 模組-->今日午餐資訊 區塊,出現錯誤訊息?
2018-11-08 15:28

Tad 老師 您好!
我想用 mytabs (我的標籤)模組,放入午餐資訊 模組-->今日午餐資訊 區塊,

可是會出現如附圖的錯誤,

請問如何處理?

Thanks.

2F
tad
:
2018-11-13 17:07

別再用 mytabs 了...

會有問題的

3F
Benjamin Franklin
:
2018-11-13 21:25

OK, thanks.

1F
徐嘉裕
: 請問學校單位要先登錄才能使用午餐資訊模組功能嗎??
2018-07-02 20:38

TAD老師您好

按照您的教學在午餐資訊 » 系統基本設定設好了學校編號設定

可是午餐資訊還是沒有顯示任何內容

去官網看也沒有顯示資料?是需要學校單位先登錄核准後才能使用這項功能嗎??

不好意思再請老師指導一下,謝謝!!

2F
徐嘉裕
:
2018-07-02 20:40

對吼~放暑假了!!我熊熊想起來呢~難怪不供餐~謝謝老師的模組~感恩!!

1F
陳淑貞
: 今天的午餐資訊又沒有抓到資料
2018-05-16 13:26
連續二天都有資料,但是今天又沒有了..
2F
tad
:
2018-05-16 14:21
更新版本後,下次抓不到資料就會出現重抓按鈕...

1F
小梁
: 請輸入標題
2018-05-11 11:01
Tad兄您好:
目前遇到無法正常示菜單的狀況,我發現點選模組首頁的【點此可至校園食材登錄平臺觀看詳細資訊】,連結中不會帶出學校的編號,不知道這是不是模組無法顯示當日菜單的原因?(在食材登錄平台上107-05-11的菜單是看得到的)
2F
tad
:
2018-05-11 11:02
有更新為 1.1 了嗎?
3F
tad
:
2018-05-11 11:04
此外,似乎沒有設定學校編號阿~
4F
小梁
:
2018-05-11 11:33
Tad兄:有設定編號,而且在偏好設定中看得到,但是到資料庫中看【xx_tad_lunch3_data_center】資料表,裡面卻是空的,不知道是怎麼回事?
http://campus-xoops.tn.edu.tw/uploads/tad_discuss/image/.thumbs/DiscussID_4511_1.pnghttp://campus-xoops.tn.edu.tw/uploads/tad_discuss/image/.thumbs/DiscussID_4511_2.png
5F
小梁
:
2018-05-11 11:34
已更新到1.1版,也試過重安裝了,狀況依然一樣。
6F
tad
:
2018-05-11 12:26
可以的話,給我網址帳密,我測試一下
7F
小梁
:
2018-05-11 14:17
這是給「小梁」的悄悄話喔!
8F
tad
:
2018-05-11 14:33
修改 D:\XAMPP\php\php.ini
把時區 date.timezone 改為 Asia/Taipei
然後重啟apache試試
9F
小梁
:
2018-05-12 10:08
Tad兄:
謝謝您,我試著修改XAMPP的時區設定,雖然date.timezone改為Asia/Taipei並重啟Apache了,但是從站長工具箱看,時區仍然維持Europe/Berlin,您知道這是怎麼回事嗎?
10F
小梁
:
2018-05-12 21:01
Tad兄:
問題已解決,原來是因為XAMPP的php.ini檔內設定時區的程式碼在最後面幾行,時區的問問題已經解決了,謝謝。
11F
小梁
:
2018-05-14 10:25
Tad兄你好:
我的學校網站時區已改為Asia/Taipei,但今日(5/14)的午餐資訊模組,仍然無法顯示菜單資料,且模組首頁的下方連結並沒有呈現school參數,以上問題如附件圖片所示,麻煩您看看問題在哪兒,謝謝。
http://campus-xoops.tn.edu.tw/uploads/tad_discuss/image/.thumbs/DiscussID_4531_1.pnghttp://campus-xoops.tn.edu.tw/uploads/tad_discuss/image/.thumbs/DiscussID_4531_2.pnghttp://campus-xoops.tn.edu.tw/uploads/tad_discuss/image/.thumbs/DiscussID_4531_3.png
12F
陳淑貞
:
2018-05-14 10:52
我們學校也是,食材平台已經有資料了,可是學校仍然抓不到
http://campus-xoops.tn.edu.tw/uploads/tad_discuss/image/.thumbs/DiscussID_4532_1.png
13F
tad
:
2018-05-14 11:17
經回報才發現是新安裝的都有此問題
所以是程式bug,新版已釋出
東榮已處理好
但豐榮的線上更新有問題(請把modules目錄整個設成644好了,擁有者也請統一一下)
所以,請手動更新
14F
小梁
:
2018-05-14 14:17
Tad兄:感謝您協助,目前進來看了以後,不管用IE或是Chrome、Firefox等瀏覽器,發現菜名都變成如圖的一堆問號,我該做什麼調整呢?謝謝。
http://campus-xoops.tn.edu.tw/uploads/tad_discuss/image/.thumbs/DiscussID_4534_1.png
15F
tad
:
2018-05-14 14:20
資料表編碼錯誤
請改為 utf8_generial_ci 即可
16F
小梁
:
2018-05-14 14:20
資料庫裡看到的校名和菜名都是問號,如圖。
http://campus-xoops.tn.edu.tw/uploads/tad_discuss/image/.thumbs/DiscussID_4536_1.png
17F
tad
:
2018-05-14 14:23
幫您處理完了
18F
小梁
:
2018-05-14 15:56
感謝您百忙之中協助處理,萬分感謝。
1F
陳淑貞
: 依照說明設定了,可是一直無法顯現菜單
2018-05-11 07:53
2F
陳淑貞
:
2018-05-11 07:59
可是食材登錄平台是有的
http://campus-xoops.tn.edu.tw/uploads/tad_discuss/image/.thumbs/DiscussID_4497_1.png
3F
tad
:
2018-05-11 08:17
食材登錄平台也沒有 2018-05-11 的喔~
4F
陳淑貞
:
2018-05-11 08:44
可是點選日期,5/10也沒出現
http://campus-xoops.tn.edu.tw/uploads/tad_discuss/image/.thumbs/DiscussID_4499_1.png
5F
tad
:
2018-05-11 08:48
那我就得看一下網站設定(甚至是資料庫是否有抓到資料)才知道是怎麼回事了。
6F
tad
:
2018-05-11 08:50
我看 2018-05-09 是有的...
所以,擷取功能應該是正常的
是否方便給我資料庫帳密,我觀察一下資料庫到底存了什麼東西。
或許可以改善這種情形
7F
陳淑貞
:
2018-05-11 08:52
這是給「陳淑貞」的悄悄話喔!
8F
tad
:
2018-05-11 09:31
貴校的更新機制怪怪的,似乎沒辦法線上更新
先手動更新為 1.1 試試吧。
9F
tad
:
2018-05-11 09:39
暫時幫您用反安裝方式,然後重裝
如此資料會清空重抓
應該就正常了
不過還是要更新模組,以後才不會有類似問題
10F
陳淑貞
:
2018-05-11 09:44
感謝吳老師,剛才測試完全正常
1F
小梁
: 關於午餐資訊模組(Tad_lunch3)安裝好之後,也更新到最新版了,我應該要到哪兒修改學號編號呢?
2018-05-10 22:38
請問Tad:
關於午餐資訊模組(Tad_lunch3)安裝好之後,也更新到最新版了,我應該要到哪兒修改學號編號呢?
我依照模組的說明點選連結到【偏好設定】後,並沒有看到任何可以輸入學校編號的欄位或連結,應該怎麼辦呢?
我的伺服器平台是Server 2016,在XAMPP上執行XOOPS 2.5.9。
以上謝謝站長解惑!
2F
tad
:
2018-05-10 23:09
就tad_lunch3偏好設定阿...
模組後台不是有說明?
3F
小梁
:
2018-05-10 23:32
找到了,謝謝。看來是我誤會了。
因為我是點選【設定說明頁】的第4點後方連結,結果連到網站的【一般設定】頁面了,所以才找不到想設定的欄位。這個連結是不是自動出現的嗎?或是可以手動拿掉,以免使用者誤點,謝謝。
4F
tad
:
2018-05-10 23:35
哎呀~是bug
5F
小梁
:
2018-05-10 23:42
有勞您處理了。另外我設好學校編號後,回到模組首頁觀看,學校名稱跟菜名都變成了一堆問號,不知道是哪裡設錯了呢?要怎麼修正呢?
6F
tad
:
2018-05-10 23:51
那就有可能是您資料庫的預設編碼不正確了