:::
校園網站輕鬆架一般討論區

xoops2.5.6能直上2.5.8嗎?

discuss pic 2017-07-28 22:33:49
請問一下,若是主機(ubuntu12.04+xoops2.5.6)太老了,換台新機裝ubuntu16.04,是不是要裝好xoops2.5.6,然後把匯出的資料庫匯入,再將它升級到2.5.8才行呢?
discuss pic 2017-08-01 09:48:48
裝好新的主機
把網站原封不動搬到新主機
然後在新主機升級網站到最新版
這樣才是正確作法。

完整作法:
http://campus-xoops.tn.edu.tw/modules/tad_book3/page.php?tbdsn=417
discuss pic 2017-08-04 00:36:20
謝謝TAD老師
目前我裝好虛擬機(UBUNTU16.04)在測試,但只能裝XOOPS2.5.8,請問我是安裝2.5.8後把舊網站直接整個複製過去,再跑一次UPGRADE嗎?另外在匯入資料庫時,有出現rank_date的錯誤,該如何解決呢?可以直接把那行刪掉嗎?
discuss pic 2017-08-04 00:38:29
解決不了
所以才說這種方式不對
請按照我之前說的方式來做。

裝好新的主機
把網站原封不動搬到新主機(此時網站無法正常運作無所謂)
上傳新版檔案(2.5.9)蓋掉舊檔
直接執行 http://xxx.xxx/upgrade(此時就會看到升級畫面,登入後升級)
在新主機升級網站到最新版,這樣就大功告成了!
這樣才是正確作法。
discuss pic 2017-08-04 00:52:55
老師是說不需要先安裝XOOPS2.5.8囉?
講義的意思是備份網頁目錄,xoops_data,xoops_lib,並匯出網站的資料庫
然後到新主機上面用舊的三個目錄覆蓋過去,匯入舊的資料庫,這樣對嗎?
還有現在2.5.9現在可以放心裝了嗎?
:::

計數器

今天: 1196119611961196
昨天: 1748174817481748
總計: 1300529130052913005291300529130052913005291300529

災害示警