:::
即時留言簿

關於2.5.10與BootStrap4升級補丁

discuss pic 2019-05-27 01:52:33

由於主機已用急救版站長工具箱將所有模組更新完畢(包括BootStrap4),

也如tad老師所言回到原本的站長工具箱想升級2.5.10 受挫。

顯示:Error : Error: Call to undefined method XoopsModules\Tadtools\Utility::mkdir()

 

於是,利用另外一個主機,新安裝了2.5.10,當然所有模組也都是最新的,

最後想去補丁BootStrap4時,還是失敗了。跳出下圖:

也是Error : Error: Call to undefined method XoopsModules\Tadtools\Utility::mkdir()

 

發現這問題,趕緊給tad老師處理,感謝。

discuss pic 2019-05-27 09:19:35

如果是用這個網站的xoops2.5.10正體中文版檔,應該已經自帶補丁,不過tad_adm要正常顯示,tad後台則是一定要安裝的,我猜應該是這樣吧~

discuss pic 2019-05-27 09:26:36

其實已經有補了,只是還沒是釋出而已

如果沒有用到school2019佈景,BootStrap4補丁實際上也用不到

discuss pic 2019-05-27 11:05:36

想到補丁,插一個題外話

xoops預設資料庫編碼為utf8,如果改用utf8mb4可能會更好!?

utf8在實務上遇到姓名罕見字或是想使用emoji表情符號時就會出現問題

事實上多年前在製作討論區手機版時就想引入emoji,但是因為編碼問題而作罷

大家在遇到會員姓名罕見字時會用什麼方式解決?

 

:::

QR Code 區塊

http%3A%2F%2Fcampus-xoops.tn.edu.tw%2Fmodules%2Ftad_discuss%2Fdiscuss.php%3FDiscussID%3D6413%26BoardID%3D3

計數器

今天: 1445144514451445
昨天: 1840184018401840
總計: 3281758328175832817583281758328175832817583281758