:::
Tad Tools 工具包

想問支援jQuery3.5.1問題

discuss pic 2021-11-05 17:09:42

因為xoops校網弱點檢測到

JQuery 1.2 < 3.5.0 多個XSS,需Upgrade to JQuery version 3.5.0 or later.

想一想...在Tad Tools 之前工具包完整版3.4版就有支援 jQuery3.5.1

今天再更新到最新Tad Tools 3.46版本後

xoops網站原始碼檢視,點選以下 jquery.js(圖示紅色框),只看到支援 jQuery v3.4.1,我是不是點錯連結檔案了?

discuss pic 2021-11-05 17:14:29
tad

jquery 是吃 XOOPS 內建的,也就是 /xoops_lib/Frameworks/jquery

跟 tadtools 其實沒什麼關係

discuss pic 2021-11-05 17:19:22

剛進去 /xoops_lib/Frameworks/jquery,看到jquery.js了

所以現在目前xoops只支援到jquery 3.4.1囉?

discuss pic 2021-11-05 17:27:45
tad

就自己升級阿

discuss pic 2021-11-05 17:33:31

謝謝tad,小弟不敢升啦,怕升了之後網站會有「意想不到的結果」。

discuss pic 2021-11-08 08:41:01
tad

還好啦,就把原本的備份一下,換上新版的,應該沒事

我把本站的換成了 jquery 3.6.0 ,目前看起來也都正常

discuss pic 2021-11-29 14:58:34
這是給「李哲安」的悄悄話喔!
第一頁 上一頁 1 下一頁 最後頁
:::

http%3A%2F%2Fcampus-xoops.tn.edu.tw%2Fmodules%2Ftad_discuss%2Fdiscuss.php%3FDiscussID%3D8714%26BoardID%3D6

計數器

今天: 253253253
昨天: 3766376637663766
總計: 6019751601975160197516019751601975160197516019751