All Posts

1F
林永森
: 更新tadnews後,如果有文章設成草稿,就無法看到文章管理了。
2019-10-16 09:46
tad老師您好:
我有一篇文章設成草稿後,進後台本站消息的文章管理,會只剩下剛剛那一篇草稿文章的標題而已。
2F
tad
:
2019-10-16 09:52

有打內容嗎?

(需協助處理的話請留下網址及資料庫帳密)

3F
林永森
:
2019-10-16 10:24
這是給「林永森」的悄悄話喔!
4F
tad
:
2019-10-16 10:55

已經有修正了

請再更新模組即可

5F
林永森
:
2019-10-16 11:12
已經正常了,謝謝tad老師。
1F
楊文察
: 這是給「tad」的悄悄話喔!
2019-10-15 20:04
這是給「tad」的悄悄話喔!
1F
曾柏叡
: 維修通報附加檔案問題
2019-10-08 11:55

老師好:請教老師如何可以將照片改成檔案方式如PDF、DOC、XSL方式

感謝老師

2F
曾柏叡
:
2019-10-08 21:45

老師晚安,請教該題有解嗎?需修改那些呢?感恩

3F
曾柏叡
:
2019-10-09 11:36

Tad老師午安,請教該題有解嗎?需修改那些呢?感恩

4F
tad
:
2019-10-09 11:38

如果您懂PHP的話

應該追一下程式碼就會改了

如果不懂

那有一堆地方要改(包括顯示、新增、修改、刪除等部份)

恕我沒時間可以一一查找說明

1F
吳智偉
: 維修通報模組,按儲存後,網頁轉圈很久...推測是寄email的問題,但我解決不了,想求助
2019-10-05 10:46

Tad老師您好:

本校有在用[維修通報]模組,我設定好後,用了好長一段時間都沒有問題,大約半年前開始出問題(我沒改過任何設定),當有人填報後,網頁會一直轉圈圈很久,超過1分鐘沒動作,然後出現寄信失敗(但填報內容有成功寫入)。我檢查了我的gmail帳號,低功能安全性,我還是有開啟,一直找不到原因。

昨天我把xoops大升級,全部升到最新,所有功能都正常,就只有寄信的問題還在,網頁轉圈還是很久,不過只要願意等,變成有寄出信了。

想求助的就是,該怎麼檢查問題?會是google設定的問題嗎?
感謝老師

2F
tad
:
2019-10-05 10:48

寄信功能跟主機設定有關

跟XOOPS或收信沒什麼關係...

檢查主機的寄信功能是否正常吧~

3F
吳智偉
:
2019-10-05 11:24
感謝老師神速回覆,馬上去查
4F
曾柏叡
:
2019-10-08 17:10

mail relay.

1F
花誌陽
: Tad Themes 佈景管理無法安裝
2019-10-08 15:42
Tad Themes 佈景管理

顯示下列訊息:
無法安裝 tad_themes 錯誤(s):

正在安裝佈景管理

Specified key was too long; max key length is 1000 bytes
2F
tad
:
2019-10-08 15:43

資料庫的預設編碼不正確吧...

請改為 utf8_general_ci

1F
黃祈霖
: 更新到最新版後給管理權還是無法審查?
2019-10-08 12:30

更新到最新版後給管理權還是無法審查,只有管理者看得到審查的界面…

想請同仁幫忙審查都不行??

是設定的問題嗎?

感謝啦!!

1F
hirokofan
: 即時空氣品質及天氣(air_weather) 區塊造成網頁無法開啟
2019-10-07 08:50

最近有學校發現網站無法開啟,需要將「即時空氣品質及天氣」區塊關閉才會正常,請問有學校遇到類似的情形嗎?

我測試的狀況是,如果使用「主要AQI資料來源」就會造成網頁無法開啟,將主要AQI來源註解後使用「次要AQI資料來源」則是正常的

(直接連https://opendata.epa.gov.tw/ 看不出有什麼問題)

2F
tad
:
2019-10-07 08:52

有發現,7:30~8:30這段時間會出問題

1F
李哲安
: 「批次預約」連結隱藏的方法...
2019-10-05 17:39

若想把「批次預約」連結隱藏...

嘗試在該模組header下,註解掉$interface_menu[_MD_JILLBOOKIN_SMNAME2] = "batch.php";

即可成功。

不知這樣做,是否為正確隱藏的方法?

1F
Mavericks
: 無法安裝模組
2019-10-04 09:42

出現下列訊息

無法安裝 kw_club  錯誤(s):

正在安裝社團報名系統

Invalid default value for 'club_start_date'

請問可以解決嗎?

 

2F
tad
:
2019-10-04 09:44

先關閉資料庫的嚴格模式或許會更快一點

3F
Mavericks
:
2019-10-04 15:22

已在/etc/my.cnf檔案中 加入一行 sql_mode=NO_ENGINE_SUBSTITUTION,STRICT_TRANS_TABLES,再重新執行安裝,已不會出現上述的錯誤訊息,但也無法安裝成功,像是沒發生任何事一般。

循環中

4F
Mavericks
:
2019-10-04 15:31

自己手動將模組傳上去主機,依然沒反應,無法成功

5F
tad
:
2019-10-04 16:01

需要協助的話,請留下網址帳密

不然各主機環境、狀況、設定都不同,實在無法用想像的方式來幫您解決問題

6F
Mavericks
:
2019-10-04 21:16
這是給「Mavericks」的悄悄話喔!
7F
tad
:
2019-10-04 21:43

MySQL嚴格模式沒關

請把 STRICT_TRANS_TABLES  刪掉(有加上該行表示要啟用嚴格模式)

[mysqld]
sql_mode = NO_ENGINE_SUBSTITUTION

另記得重啟MySQL後再安裝試試

8F
Mavericks
:
2019-10-04 23:27

還是會出現下面的錯誤訊息

無法安裝 kw_club  錯誤(s):

正在安裝社團報名系統

Invalid default value for 'club_start_date'

但是我轉念一下,我下載1.3版來安裝,就可以正常安裝使用了,然後再線上更新,目前測試還OK

1F
曾柏叡
: 修改文字內容
2019-10-03 16:54

老師好請問一下圖示紅色圈起部分請問是在那一個檔案修改,感謝

2F
tad
:
2019-10-03 17:45

語系檔

\language\tchinese_utf8\global.php

3F
曾柏叡
:
2019-10-03 20:50

感謝Tad老師指導