:::
Tad Themes 佈景管理

更新後school系列布景無法顯示系統區塊

discuss pic 2019-01-03 12:12:07

更新後school系列布景無法顯示系統(system模組)所屬的區塊,如會員選單、登入、誰在線上等

使用school2014布景

http://hc.cyc.edu.tw/?xoops_theme_select=school2014

使用default布景

http://hc.cyc.edu.tw/?xoops_theme_select=default

discuss pic 2019-01-03 12:37:35


我也是有這個問題,使用者區塊好像就沒辦法用了

也是用 shool2014 這個佈景

  •  
    1) Snipaste_2019-01-03_12-34-54.png
  •  
    2) Snipaste_2019-01-03_12-35-07.png
discuss pic 2019-01-03 12:42:29

還有各模組內的頁面選單的排列也怪怪的

附圖是站長工具箱

  •  
    1) Snipaste_2019-01-03_12-41-32.png
discuss pic 2019-01-03 12:52:01

to hsun:

「各模組內的頁面選單的排列也怪怪的」,控制台介面(Control Panel GUI) 要改用tad老師的自適應後台才行,從站長工具箱安裝上去就可以解了

「系統所屬區塊消失的問題」似乎是只要用到tadtools的template的布景就會受到影響

discuss pic 2019-01-03 13:18:22

請確定是XOOPS 2.5.9

discuss pic 2019-01-03 14:02:31

XOOPS 是 2.5.9

XOOPS 2.5.9
5.5.9-1ubuntu4.25
5.5.60-0ubuntu0.14.04.1
3
Linux
240M
120
150
256M
220M

 

discuss pic 2019-01-03 14:09:30

給我測試帳密吧

discuss pic 2019-01-03 14:10:03

很早前就更新是 2.5.9 了

還是要更新到這個版本才可以? XoopsCore25-2.5.9_tw_for_upgrade_20190103.zip 

  •  
    1) Snipaste_2019-01-03_14-08-43.png
discuss pic 2019-01-03 14:15:05

不用,都一樣

佈景有升級過嗎?

discuss pic 2019-01-03 14:24:20

有,模組全更新最新版的了

還有不知道為什麼更新後,模組隨選的圖示會變那麼大

  •  
    1) Snipaste_2019-01-03_14-23-16.png
discuss pic 2019-01-03 14:25:08

請安裝 tad後台

discuss pic 2019-01-03 14:43:26

謝謝

安裝 tad 後台後,正常顯示了

不過區塊的部分還是沒辦法顯示。

discuss pic 2019-01-03 14:47:40

我問的是「佈景」有沒有更新

不是指模組

 

discuss pic 2019-01-03 14:56:24

有啊,還有新版的嗎?

  •  
    1) Snipaste_2019-01-03_14-55-46.png
discuss pic 2019-01-03 15:53:55

我找到問題了,我的安裝方式是砍掉資料夾再上傳,開除錯發現缺少

modules/tadtools/themes_common/blocks_tpl

這個資料夾,補上之後區塊就出現了

 

用站長工具箱更新的tadtools有這個資料夾,各區塊顯示也都正常,是否是因為更新的模式不同而有差異?

discuss pic 2019-01-03 15:57:30

如果是這樣...那真的是bug

因為 blocks_tpl 理論上應該是不需要

blocks_tpl 已經移到themes3_tpl及themes4_tpl下

我再檢查看看

discuss pic 2019-01-03 15:59:49

哎呀~所有舊佈景都是直接讀 modules/tadtools/themes_common/blocks_tpl

看來舊佈景也都要更新

discuss pic 2019-01-03 16:45:58

剛有試了 school2019 的佈景,使用者區塊出現了,但快速登入的區塊沒辦法顯示出來

discuss pic 2019-01-03 17:14:49

剛才發現還是需要更新到這個版本才行 XoopsCore25-2.5.9_tw_for_upgrade_20190103.zip 

不然沒有Bootstrap4可用,

舊的XOOPS2.5.9(沒有Bootstrap4)+school2019 + tad自適應後台1.7三個條件同時發生的情況下,一進後台就整片白

(如果tad自適應後台是1.6,或使用school2019以外的布景進入後台都不會發生這個問題)

解法是 XOOPS2.5.9用上面的檔案更新(class資料夾放上去即可)

 

discuss pic 2019-01-03 21:11:16

安裝BootStrap4補丁就好了

:::

QR Code 區塊

QR Code

計數器

今天: 7575
昨天: 2905290529052905
總計: 2528180252818025281802528180252818025281802528180